Descripción del Problema

Al realizar alguna transacción en Advanta aparece un mensaje de registro en uso por un usuario y no permite llevar a cabo la transacción.



Error

<registro> en uso por <usurio,id> en <base_datos>



Causa

La Base de Datos sobre la que opera Advanta no permite que más de un usuario modifique un mimso registro al mismo tiempo, esto para evitar redundancia de información.

Por lo que si en el mismo instante otro usuario esta realizando modificaciones al registro, aparece dicho mensaje y no lleva a cao la transacción.



Solución

Se sugiere esperar a que el usuario que indica el mensaje termine de utilizar la funcionalidad o registro.

Si pasara mucho tiempo y el registro no se libera, puede pasar que el usuario indicado en el mensaje haya quedado en el limbo en la Base de Datos, es decir no se realizó una correcta liberación del registro en uso.

Para liberar al usuario de la BD en caso que haya quedado en el limbo se debe desconectar por medio del Administrador de BD de Advanta