Descripción del Problema
Al iniciar AdvantaTMB y seleccionar la Base de Datos a la cuál se desea realizar la conexión tarda mucho y aparece el siguiente mensaje de error:
Error
No se puede Establecer Conexión con la Base de Datos.
Causa
Esta situación puede tener tres causas principales:
- La Base de Datos no ha sido "levantada", no hay un servidor para la BD.
- Configuraciones erróneas en el Firewall del Servidor o del cliente
- Problemas con la red de comunicación
Solución
Primero nos debemos asegurar que la BD este "levantada" o iniciar el servicio de la Base de Datos de la siguiente forma:
En la versión 10.0 del Administrador de Bases de Datos:
- Dar clic en el Acceso Directo llamado Advanta-DB que se encuentra en el escritorio del servidor.
- Se despliega una ventana con una lista tipo checklist donde seleccionamos las Bases de Datos que deseamos subir.
- Y posteriormente damos clic en el Boton "Subir".
- Aparece una ventana de comandos donde se muestra todo el proceso, al terminar cerrar la ventana.
- Dar clic en el botón Salir.
Si las bases de datos estan levandas y aún así no es posible tener acceso a Advanta, se debe verificar la configuración del firewall del servidor y de la máquina cliente. Tomar en cuenta las siguientes consideraciones:
Servidor
Si ningun cliente puede tener acceso a Advanta y les arroja el mismo error, es más probable que la configuración errónea sea del servidor. Y se debe verficar que el Servidor permite conexiones entrantes por el protocolo TCP/IP y que los puertos de Advanta sean accesibles (2500-2590, dependiendo de configuración). Se recomienda deshabilitar temporalmente el firewall para realizar pruebas y descartar que sea éste el problema.
También es importante revisar que la red a la que esté conectado el servidor sea una red privada o de trabajo. No pública.
Maquina Cliente
Si sólo una máquina tiene problemas para entrar a Advanta, se debe revisar que el firewall permita conexiones salientes de la máquina. Se recomienda deshabilitar temporalmente el firewall para realizar pruebas y descartar que sea éste el problema.
Si a pesar de estar levantadas las BD y verificar la configuración del firewall se sigue teniendo problemas se sugieren los siguientes pasos para verificar si se tiene comunicación desde el equipo al servidor:
En una ventana de msdos, realizar un ping a la dirección ip del servidor, ejemplo:
C:\>ping 192.168.x.x
En una ventana de msdos, realizar un ping al nombre del servidor, ejemplo:
C:\>ping nombre_servidor
Revisar que el firewall no este bloqueando conexiones salientes en la red local
En caso de tener problemas con el ping a la ip del servidor se debe verificar la configuración de la red en la máquina y que este correctamente conectada.
En caso de tener problemas con el ping al nombre del servidor se puede agregar el servidor a la lista de hosts de windows en el archivo ubicado en:
C:\Windows\system32\drivers\etc\hosts
O si es necesario se debe limpiar el caché del dns de la máquina con el siguiente comando en msdos:
C:\>ipconfig /flushdns